워드프레스 구텐베르크 편집기 비활성화하기

어제 워드프레스 5.0 버전이 릴리즈되었습니다. 5.0에는 비주얼 편집기인 구텐베르크가 코어에 통합되었습니다. 이제 구텐베르크가 글과 페이지의 기본 편집기가 되었습니다.

구텐베르크를 사용하면 보다 편리하고 창의적으로 글을 작성할 수 있습니다.

하지만 구텐베르크는 충분히 안정화가 되지 않았기 때문에 현재 사용 중인 테마나 플러그인과 충돌을 일으킬 수 있습니다. (아바다Divi 같은 인기 테마는 구텐베르크와의 호환성을 위해 적극적으로 대응하고 있습니다.)

사용 중인 환경에서 충돌이 발생하거나 구텐베르크를 사용하고 싶지 않은 경우 구텐베르크 대신 고전 편집기를 설치하여 사용할 수 있습니다.

Classic Editor는 2011년 12월 31일까지 공식 지원됩니다.

The Classic Editor plugin will be officially supported until December 31, 2021.

고전 편집기는 새로운 편집기인 구텐베르크로 전환을 하는 과정을 돕기 위한 과도기적인 플러그인입니다.

지원이 종료될 시점에 워드프레스 팀이 고전 편집기 플러그인이 계속 유지할 필요가 있을지 평가하여 사용자 수가 적으면 지원을 종료한다고 하네요.

링크된 글을 보면 어떤 사용자는 구텐베르크(블록 에디터)를 사용하지 않고 고전 편집기를 무한히(infinitely) 사용하고 싶다고 하네요.ㅎㅎ 설치할 때 기본 편집기를 구텐베르크와 고전 편집기 중에서 선택할 수 있도록 하면 좋겠다는 생각이 드네요.

고전 편집기 플러그인을 설치하여 활성화하면 고전 편집기와 구텐베르크 중에서 기본 편집기를 선택할 수 있습니다. 다음 코드를 테마의 함수 파일에 추가하면 구텐베르크가 완전히 비활성화됩니다.

// Gutenberg 비활성화하기
add_filter('use_block_editor_for_post', '__return_false');

2019년 1월이 되면 버그가 수정된 패치가 나올 예정입니다. 조금 기다렸다가 1월에 업데이트된 버전이 릴리즈될 때 업데이트하는 것도 고려해볼 수 있습니다.

참고로 워드프레스 5.0의 코드명은 “Bebo”입니다. Bebo는 쿠바의 재즈 뮤지션 Bebo Valdés의 이름에서 따온 것이라고 하네요.

워드프레스 창립자인 뮬런버그(Matt Mullenweg)가 재즈 애호가라고 하네요(“Matt is a jazz lover, and an avid photographer”). 그 때문인지 Hello Dolly 같은 생뚱맞은 플러그인이 워드프레스를 설치할 때 함께 설치되는 것 같습니다.ㅎㅎ

참고:

Recent Posts

Leave a Comment

Start typing and press Enter to search